Aktualizacja skryptu z 1.4 do 1.8.9

Założony przez zeeltom.

https://mybboard.pl/temat-wylogowuje-z-acp_60561
Co jest najśmie­szniej­sze w ludziach? Zaw­sze myślą na od­wrót: spie­szy im się do do­rosłości, a po­tem wzdychają za ut­ra­conym dzieciństwem. Tracą zdro­wie by zdo­być pieniądze, po­tem tracą pieniądze by odzys­kać zdro­wie. [...] Żyją jak­by nig­dy nie mieli um­rzeć, a umierają, jak­by nig­dy nie żyli.   - Paulo Coelho
TaniDedyk.pl
(25.12.2016, 00:07)zeeltom napisał(a): I za każdym wejściem a ACP muszę potwierdzać konto ACP admina i pomimo potwierdzeń nic nie mogę zmienić.
https://mybboard.pl/thread-59161.html
Próbowałem upgrade do wersji 1.6.xx i też się wywaliło na bazie danych. Nie mam już siły do tej zabawy/

O to chodzi, że gdy wchodzę w ustawienia ACP, to wymaga potwierdzenia każdego kroku logowaniem do ACP i nic to nie daje.

Zapłacę jakieś rozsądne pieniądze, kto mi to zrobi. Mam już tego kombinowania dość.
myCreedo napisał 25.12.2016, 01:00:
Zapraszam do działu Giełda ogłoszeń ;)
Jeszcze jedno pytanie. W którym katalogu znajduje się plik z zapisem strony głównej, która się wyświetla po wejściu na forum?
Zmieniłem silnik forum, a chcę przerzucić parę linijek ze starego forum i nie mogę tego odnaleźć. Normalnie to zmieniałem w indeksie strony głównej, ale to z silnika z forum, a chcę to podejrzeć w kopii starego forum i przepisać do nowego forum.
Niestety wszelkie próby upgrade do nowszych silników zakończyły się niepowodzeniem.
(25.12.2016, 00:22)Fyeem napisał(a):
(25.12.2016, 00:07)zeeltom napisał(a): I za każdym wejściem a ACP muszę potwierdzać konto ACP admina i pomimo potwierdzeń nic nie mogę zmienić.
https://mybboard.pl/thread-59161.html
Może to i fajne, tylko wkurza mnie, że to, że są takie niedoróbki. Powinno się wszystko instalować prawidło, beż żadnego grzebania potem w ustawieniach. Jak coś robić, to robić porządnie. Bo wygląda to tak, jakbyś kupił samochód i potem grzebał w nim tygodniami, żeby pojechał.
Akurat tu nic nie kupujemy, ale powiedzenie Einsteina nie traci racji bytu. Jak coś robić, to robić to porządnie.
Przez te zmiany utraciłem forum z kilkuset tysiącami wpisów.
Plik index w public_html.
(25.12.2016, 09:08)zeeltom napisał(a): to robić to porządnie.
Przez te zmiany utraciłem forum z kilkuset tysiącami wpisów
Już nie przesadzaj, że to wina silnika. Jedyne co zepsuło forum to niestety Ty.

Zaniedbałeś aktualizacje. Kupiłeś samochód który następnie postawiłeś na 5lat do garażu. Nie dziw się, że przed ponową jazdą musisz coś w nim pogrzebać.
Wybór phpbb by przemo jest chyba najgorszym z możliwych. Skrypt nie jest wspierany już od dosyć dawna.

Jeżeli nadal chcesz zaktualizować stare forum to odezwij się na PW.
Przede wszystkim - co z kopią zapasową? Zapomniałeś o jej wykonaniu przed próbą aktualizacji?
Druga rzecz, przenieś tymczasowo całą zawartość inc/plugins do jakiegoś innego katalogu, aby uniknąć problemów z wtyczkami.
   
No więc tak. Co to są za jaja z logowaniem na forum? Wyrzuca mnie ciągle przy logowaniu. Już mnie szlag trafia. 3 razy generowałem nowe hasło i ciągle go nie przyjmowało. Jakoś się w końcu udało :)
Błędem bazy danych i jej przywracania była przestrzeń dyskowa serwera która była ustawiona dla baz na 50 MB, podczas gdy moja baza miała 120 MB. Zmieniłem, poszło.
Uaktualniłem silnik do wersji 1.8.9 i teraz mam problemy.
Forum jest pod adresem: zyrardow24h.eu
A problemy polegają na kilku sprawach.
Może najpierw napiszę, co nie sprawia problemów: starzy użytkownicy mogą się normalnie zalogować na stare nicki i hasła.
Goście też mogą pisać bez problemu.
Natomiast problemem jest brak zdjęć w postach, niemożliwość zarejestrowania się nowych użytkowników i problem z cytowaniem.
Przynajmniej do tej pory takie usterki mi zgłoszono.
Faktycznie przy rejestracji wyskakuje nieznany błąd, który widać na załączonym obrazku:
(tu też nie działa [img])
[attachment=11092] Nie wiem dlaczego pojawiły się dwa obrazki na górze :D
Wywaliłem wszelkie captcha itp przy logowaniu i nie wiem co to za błąd.
Co do zdjęć, to przeszukałem cały internet i wszelakie podpowiedzi w stylu UCP i zapytania do bazy danych przewaliłem. To nie pomaga. Zdjęć nie widać, ani w postach, ani w szybkiej edycji. Pojawiają się tylko w pełnej edycji, ale w postach już nie.
Cytowanie też nie działa, klikam w cytowanie i nic się nie dzieje.
Pomoże ktoś?

Poprawiłem te obrazki na górze, jest teraz tylko jeden :)

Jeszcze jedna sprawa.
Na stronie głównej mogłem zawsze pozamykać wyświetlanie działów i to było pamiętane. Teraz zamykam i gdy wchodzę ponownie wszystko jest niepozamykane.
Strona nie pamięta ustawień.

Teraz wylazło jeszcze coś innego: "Typ pliku, który załączono, nie jest obsługiwany. Usuń załącznik i spróbuj ponownie".
Jako załącznik wysyłam obrazek .jpg i nie chce go przyjąć pomimo, że ACP i typach załączników są pozaznaczane wszystkie typy.
Wywaliłem wszystkie pluginy i teraz mogę się rejestrować. Widocznie któyś z pluginów bruździ, który? Ktoś coś pisał o Seo. Spróbuję najpierw z nim.

wnr.php bruździ.
Wywaliłem i jest z rejestracją OK.

No dobra, a co ze zdjęciami i resztą?
Nie działa też przycisk "cytuj" pozostałe obok działają.

I następne: zaznaczam wątki do usunięcia (kilka) i mam komunikat, żeby zaznaczyć wątki (choć je zaznaczyłem) i że sesja trwała za długo.
To sam mam przy kasowaniu użytkowników, zaznaczam kilku, a nie kasuje ich wszystkich. Muszę ręcznie po kolei usuwać każdego.

Zaznaczam wątek, próbuję go usunąć i mam taki komunikat: "Nie zaznaczono żadnego wątku lub twoja poprzednia sesja wygasła (automatycznie po 1 godzinie nieaktywności). Wybierz inne wątki i spróbuj ponownie."
(06.01.2017, 08:39)zeeltom napisał(a): No dobra, a co ze zdjęciami i resztą?
Może daj link do jakiegoś przykładu?
(06.01.2017, 08:39)zeeltom napisał(a): Nie działa też przycisk "cytuj" pozostałe obok działają.
Podaj konto testowe.
(06.01.2017, 08:39)zeeltom napisał(a): I następne: zaznaczam wątki do usunięcia (kilka) i mam komunikat, żeby zaznaczyć wątki (choć je zaznaczyłem) i że sesja trwała za długo.
https://community.mybb.com/thread-206896.html
Podziękowali: zeeltom
login tester hasło 123456

Temat ze sporą ilością zdjęć: http://zyrardow24h.eu/forum/thread-6680.html?highlight=dafi
Zresztą jako tester można samemu coś wpisać gdziekolwiek, potem posprzątam.

Pozmieniałem pliki według najniższej porady i teraz działa grupowo.
Pozostają zdjęcia, cytowanie i jeszcze jedna rzecz, ale to już na koniec, bo można z nią żyć.

Co do cytowania, to klikam "cytuj" i w szybkiej odpowiedzi na dole pojawia się napis "Zaznaczono 1 lub więcej postów do zacytowania. Zacytuj te posty teraz lub odznacz je. " Klikam na Zacytuj te posty teraz" nad okienkiem pojawia się wirujące kółeczko i nic dalej.
I co? Nikt, nic...?

Tak na marginesie, to się zastanawiam, po co wychodzą nowe wersje mybb, skoro są niedopracowane i trzeba w nich poprawiać wiele rzeczy samemu?
Nie można zrobić czegoś raz a porządnie?
(07.01.2017, 08:14)zeeltom napisał(a): I co? Nikt, nic...?

Tak na marginesie, to się zastanawiam, po co wychodzą nowe wersje mybb, skoro są niedopracowane i trzeba w nich poprawiać wiele rzeczy samemu?
Nie można zrobić czegoś raz a porządnie?
Co takiego trzeba poprawiać, raczej musisz uzupełnić swoją wiedze na pewne tematy.

Po co są wydawane? Hmmm, żeby latać wszystko w miarę możliwość developerów skryptu,. MyBB robią "wolontariusze" w swoim wolnym czasie i nikt nie ma czasu na to aby załatać wszystko jednego dnia. Przystąp do ekipy mybb.com i zobaczymy czy zrobisz wszystko od razu :)
Pomoc poprzez system prywatnych wiadomości jedynie odpłatnie.
Nie pisz do mnie prywatnych wiadomości w sprawie pomocy na forum, tak owe będą ignorowane.
Jeśli możesz zadać pytanie na forum, napisz nowy wątek.
(07.01.2017, 08:14)zeeltom napisał(a): I co? Nikt, nic...?
Nie minęły nawet 24 godziny od Twojego ostatniego posta. Zapłać za IPB wtedy będziesz mógł wytykać im błędy i oczekiwać supportu. Tutaj wszyscy robią wszystko z dobrej woli i niczego nie muszą.

(07.01.2017, 08:14)zeeltom napisał(a): Tak na marginesie, to się zastanawiam, po co wychodzą nowe wersje mybb, skoro są niedopracowane i trzeba w nich poprawiać wiele rzeczy samemu?
Nie można zrobić czegoś raz a porządnie?
Proponują najpierw spojrzeć na to co Ty robisz źle, a później narzekać na innych.
Połowa Twoich problemów jest spowodowana jakimś lipnym szablonem z nagłówkiem z wersji 1.4 (!!). Co 5 minut na Twoim forum jest inny szablon, jak mamy Ci w czymś pomóc?
Ponad to podałem link który rozwiązuje 1 bądź więcej Twoich problemów, ale Ty i tak tego nie wykonałeś...


Użytkownicy przeglądający ten wątek:

1 gości