Nieprzeczytane posty i tematy do odpowiedzi - nie reaguje na div

Założony przez BlackDog.

wersja skryptu MyBB: 1.6.8
adres forum: http://www.forum.max4game.pl/
na czym polega problem (screen, opis, komunikaty, nazwa i wersja wtyczki): Chce dostosować linki przenoszące do nie przeczytanych postów i tematów bez odpowiedzi do stylu, ale linki nie reagują na div'a.
Styl reksio.

Fragment header_welcomeblock_member

Kod:
<div class="panelmenu">
<div id="panel_menu_popup" class="popup_menu">
    <div class="panel_popup_container"><a href="{$mybb->settings['bburl']}/usercp.php" class="popup_item">{$lang->welcome_usercp}</a></div>
    <div class="panel_popup_container"><a href="{$mybb->settings['bburl']}/usercp.php?action=profile" class="popup_item">Edytuj profil</a></div>
    <div class="panel_popup_container"><a href="{$mybb->settings['bburl']}/usercp.php?action=avatar" class="popup_item">Zmień avatar</a></div>
    <div class="panel_popup_container"><a href="{$mybb->settings['bburl']}/usercp.php?action=options" class="popup_item">Edytuj opcje</a></div>
    <div class="panel_popup_container"><a href="#" onclick="MyBB.popupWindow('{$mybb->settings['bburl']}/misc.php?action=buddypopup', 'buddyList', 350, 350);" class="popup_item">{$lang->welcome_open_buddy_list}</a></div>
    <div class="panel_popup_container"><a href="{$mybb->settings['bburl']}/search.php?action=getnew" class="popup_item">{$lang->welcome_newposts}</a></div>
    <div class="panel_popup_container"><a href="{$mybb->settings['bburl']}/search.php?action=getdaily" class="popup_item">{$lang->welcome_todaysposts}</a></div>
              <div class="panel_popup_container"><!-- UNREADPOSTS_LINK --></div>
              <div class="panel_popup_container"><!-- UNANSWEREDPOSTS_LINK --></div>
</div>
</div>

W załączniku dodaj ss jak aktualnie wygląda.
Daniel Praźmo napisał 08.07.2012, 22:11:
Zły dział. Przenoszę.


Załączone pliki Miniatury
   
TaniDedyk.pl
spróbuj w tych ostatnich 2 divach dać linki <a></a> i zobacz czy będzie normalnie a raczej bedzie i to ci rozwiąże problem :D
Bez żadnego konta testowego niewiele da się powiedzieć.
lukasamd napisał(a):Bez żadnego konta testowego niewiele da się powiedzieć.

Wysłałem ci na pw dane do konta testowego.

masterofgg napisał(a):spróbuj w tych ostatnich 2 divach dać linki <a></a> i zobacz czy będzie normalnie a raczej bedzie i to ci rozwiąże problem

Próbowałem tak, nie da rady.
Wyświetla się źle, ponieważ linki zawarte w tym panelu muszą mieć klasę "popup_item". Ogólnie to ten panel jest źle napisany, bo główny div musi mieć swoją klasę, divy wewnątrz niego również, jeszcze niższe również... a dałoby się to zrobić używając tylko 1 klasy/id dla głównego elementu.

Dwa rozwiązania:
- poprawić cały kod rozwijanego panelu od strony CSS
- dodać klasę "popup_item" do linka w szablonie pluginu. Znajdziesz go w szablonach globalnych.

Te drugie rozwiązanie chyba będzie najszybsze i najprostsze.
Podziękowali: BlackDog
lukasamd napisał(a):Ogólnie to ten panel jest źle napisany, bo główny div musi mieć swoją klasę, divy wewnątrz niego również, jeszcze niższe również... a dałoby się to zrobić używając tylko 1 klasy/id dla głównego elementu.

Nie ja pisałem ten panel, styl znalazłem na waszym forum i nic w nim nie zmieniałem, wiec to autor popełnił błąd, ale cóż ważne że działa.

lukasamd napisał(a):dodać klasę "popup_item" do linka w szablonie pluginu. Znajdziesz go w szablonach globalnych.

Dodałem i jest wszystko ok, wielkie dzięki za pomoc.


Użytkownicy przeglądający ten wątek:

1 gości