Błąd Kod PHP w szablonie wypluwa błędy

Założony przez GamPL.

wersja skryptu MyBB: 16.8
adres forum: localhost
na czym polega problem (screen, opis, komunikaty, nazwa stylu/theme/szablonu): Po wpisaniu poprawnego kodu php w szablonie, pokazują się błędy

Witajcie. Zainstalowałem wtyczkę PHP in Templates (z tego forum), następnie dodałem ten kod do szablonu


<?php
$aPlayers = $query->getDetailedPlayers();
if(!is_array($aPlayers) || count($aPlayers) == 0)
{
echo("Brak graczy online");
}
else
{
foreach($aPlayers as $sValue)
{
?>
<tr>
<td class="trow1" style="text-align: center;"><?= $sValue['playerid'] ?></td>
<td class="trow1" style="text-align: center;"><?= htmlentities($sValue['nickname']) ?></td>
<td class="trow1" style="text-align: center;"><?= $sValue['score'] ?></td>
<td class="trow1" style="text-align: center;"><?= $sValue['ping'] ?></td>
</tr>
<?php
}
}
?>


Po zapisaniu i odświeżeniu strony pokazują się te dwa błędy

Kod:
Parse error: syntax error, unexpected $end in D:\_Serwer\Ampss\www\mybbdev\serwer.php(8) : eval()'d code(67) : eval()'d code on line 11

Parse error: syntax error, unexpected '}' in D:\_Serwer\Ampss\www\mybbdev\serwer.php(8) : eval()'d code(77) : eval()'d code on line 2

Co może być przyczyną tych błędów? Dodam tylko że mam też kod na pobieranie podstawowych danych z serwera, który działa bez błędów :)
TaniDedyk.pl
Co to za "=" przed "<?"?
Nie ogarniam tej wtczki ale zaczął bym od zmiany 'ping' na "ping" etc.


Użytkownicy przeglądający ten wątek:

1 gości