Kod PHP wyjeżdża poza obramowanie posta

Założony przez Up6nP.

wersja skryptu MyBB: 1.6.7
adres forum: OtIsland (to strona testowa)
na czym polega problem (screen, opis, komunikaty):

Chodzi o to, że BBcode PHP czasami strasznie wyjeżdża za post. (szukałem rozwiązania, ale znalazłem jeden temat z brakiem rozwiązania) Czy da się to jakoś naprawić? (Dla mnie to bardzo ważne) aby jakoś skrócić do pole tak jak np. code czy quote bo one nie wyjeżdżają. Próbowałem tego: https://mybboard.pl/thread-82.html ale to archiwalne i nie mam takich deklaracji. Proszę o pomoc (poniżej też załącznik jak to wygląda)
Ezio napisał 18.05.2012, 20:07:
Poprawiłem temat.


Załączone pliki Miniatury
   
TaniDedyk.pl
Spróbuj tego:
http://tkacz.pro/lamanie-linii-w-znaczniku-php-w-mybb/

Powinno pomóc na rozjazdy w kodach PHP.
Teraz występuje:

Kod:
Parse error: syntax error, unexpected ';' in /virtual/o/t/otisland.ugu.pl/inc/class_parser.php on line 1192

Ta linia wygląda tak:


return (strlen($text[0]) < 7) ? ' ' : $text[0];


Na php się za bardzo nie znam więc proszę o podpowiedź co zmienić aby było ok?
Źle coś zrobiłeś, sprawdź czy klamry się zgadzają, itp.
Wklejałem 10 razy ten kod zawsze to samo, już nie wiem. Tutaj zamieszczam:

http://wklej.org/id/756358/

Linijki, które wklejałem to linia 867 i te 4 przedostatnie
No i wkleiłeś źle...

W instrukcji jest wyraźnie napisane, aby kod funkcji wklejać przed


}
?>


czyli wewnątrz klasy, a nie poza nią...
No tak, źle przeczytałem, ale nadal błąd wyskakuje, ja to jakis nieogarnięty jestem myślałem, że teraz dobrze wstawiłem:


// Run plugin hooks
$message = $plugins->run_hooks("text_parse_message", $message);

return $message;
}
private static function deleteNbsp($text)
{
return (strlen($text[0]) < 7) ? ' ' : $text[0];
}
}
?>


Przed było tak:


// Run plugin hooks
$message = $plugins->run_hooks("text_parse_message", $message);

return $message;
}
}
?>


Sory, że tak mące głowę ale po prostu nie znam się, wiem, że instrukcje są proste, ale nie wiem gdzie teraz popełniam błąd...

Kod:
Parse error: syntax error, unexpected ';' in /virtual/o/t/otisland.ugu.pl/inc/class_parser.php on line 1192

Ja już nie wiem... Lepiej niech ktoś w ten powyższy kod za mnie wklei bo znając mnie znowu coś źle odwale.
Kod w pliku wygląda dokładnie tak samo?
Najprawdopodobniej masz zamiast "<" fragment "&lt;".
Podziękowali: Up6nP


Użytkownicy przeglądający ten wątek:

1 gości