Styl Podświetlanie aktywnych zakładek.

Założony przez Ximax.

wersja skryptu MyBB: 1.6.1
adres forum: u-rp.pl
na czym polega problem (screen, opis, komunikaty, nazwa stylu/theme/szablonu):

Witam.
Używam stylu eMaster wykonanego przez Frixona, i chcę by po kliknięciu w wybraną zakładkę została podświetlona odpowiednim obrazkiem. W razie czego wstawiam mój kod z header:



<div id="pagetop">
<div class="header_left"></div>
<div class="header_right"></div>
<div class="header">
<div id="panel">
{$welcomeblock}
</div>
<a href="{$mybb->settings['bburl']}/index.php">
<img src="{$theme['logo']}" alt="{$mybb->settings['bbname']}" title="{$mybb->settings['bbname']}" />
</a>
</div>
<div class="menu_left"></div>
<div class="menu_right"></div>
<div class="menu">
<a href="{$mybb->settings['bburl']}/index.php">Forum</a><a href="{$mybb->settings['bburl']}/search.php">{$lang->toplinks_search}</a><a href="{$mybb->settings['bburl']}/memberlist.php">{$lang->toplinks_memberlist}</a><a href="{$mybb->settings['bburl']}/calendar.php">{$lang->toplinks_calendar}</a><a href="{$mybb->settings['bburl']}/misc.php?action=help">{$lang->toplinks_help}</a>
</div>
</div>


<div id="container">
<a name="top" id="top"></a>
<hr class="hidden" />
<div id="content">
{$pm_notice}
{$bannedwarning}
{$bbclosedwarning}
{$unreadreports}
<table align="right">
<tr>
<td><a href="syndication.php"><img src="images/emasters/feed.png" /></a></td>
</tr>
</table>
<navigation>
{$board_messages}
<br />


Obrazek którym chcę by podświetlało: http://u-rp.pl/images/emasters/menu_hover.gif .

Liczę na szybką pomoc i z góry dziękuje.
TaniDedyk.pl
Twój header ma mieć taki kod jak w ostatnim poście na poprzedniej stronie.
Dalej nic, a nic...
Wrzuć ten kod jeszcze raz.
Proszę:

<div id="pagetop">
<div class="header_left"></div>
<div class="header_right"></div>
<div class="header">
<div id="panel">
{$welcomeblock}
</div>
<a href="{$mybb->settings['bburl']}/index.php">
<img src="{$theme['logo']}" alt="{$mybb->settings['bbname']}" title="{$mybb->settings['bbname']}" />
</a>
</div>
<div class="menu_left"></div>
<div class="menu_right"></div>
<div class="menu">
<li {$index_active}><a href="{$mybb->settings['bburl']}/index.php">Forum</a></li>
<li {$search_active}><a href="{$mybb->settings['bburl']}/search.php">{$lang->toplinks_search}</a></li>
<li {$members_active}><a href="{$mybb->settings['bburl']}/memberlist.php">{$lang->toplinks_memberlist}</a></li>
<li {$calendar_active}><a href="{$mybb->settings['bburl']}/calendar.php">{$lang->toplinks_calendar}</a></li>
<li {$misc_active}><a href="{$mybb->settings['bburl']}/misc.php?action=help">{$lang->toplinks_help}</a></li>
</div>
</div>



<div id="container">
<a name="top" id="top"></a>
<hr class="hidden" />
<div id="content">
{$pm_notice}
{$bannedwarning}
{$bbclosedwarning}
{$unreadreports}
<table align="right">
<tr>
<td><a href="syndication.php"><img src="images/emasters/feed.png" /></a></td>
</tr>
</table>
<navigation>
{$board_messages}
<center><script TYPE="text/javascript"
src="http://www.cpmprofit.com/ads.php?r=49169793f6d6f33ef1ea139fca20f960cca1256527507394&popup=0"></script></center>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;

<br />

Obecny kod strony różni się od tego, który podałeś, więc prawdopodobnie nie ustawiłeś stylu, który edytujesz jako domyślny (pisałem wcześniej byś to zrobił).
Solid23 ja korzystam ze stylu emaster który jest tutaj na forum w downloadzie.. lecz jak dodaje ten kod co podaliście stronę wcześniej do global.css owego stylu którego używam po zapisaniu znika on :)
Ten kod wrzucasz do szablonu header (ACP -> Style i szablony -> Szablony -> Twój szablon -> Nagłówek -> header), a nie pliku global.css.
Kod:
#menu li.current-item {
    background: url(images/emasters/menu_hover.gif);
    color: #ffffff;
    padding: 8px;
    height: 16px;
    -moz-border-radius-topleft: 5px;
    -moz-border-radius-topright: 5px;
    -webkit-border-top-left-radius: 5px;
    -webkit-border-top-right-radius: 5px;
    border-top: 1px solid #363636;
}
kod css do headera? ;] ... kod headera już wkleiłem ale i tak nie działa.
Na poprzedniej stronie znajduje się tylko kod szablonu i o nim właśnie mówiłem.
To go podmieniłem i nie działa.
Podaj adres strony. Swoją drogą - powinieneś założyć własny temat.
kubag.ugu.pl
W twoim przypadku blok odpowiedzialny za nawigację ma klasę o nazwie menu, a nie id, więc ma to wyglądać mniej więcej tak ("#" zastępujesz "."):

Kod:
.menu li.current-item {
    background: url(images/emasters/menu_hover.gif);
    color: #ffffff;
    padding: 8px;
    height: 16px;
    -moz-border-radius-topleft: 5px;
    -moz-border-radius-topright: 5px;
    -webkit-border-top-left-radius: 5px;
    -webkit-border-top-right-radius: 5px;
    border-top: 1px solid #363636;
}
Podziękowali: Trufelek
No ładnie w końcu działa ;p


Użytkownicy przeglądający ten wątek:

1 gości