Styl Blad w tabeli logowania

Założony przez ^(-.-)^.

wersja skryptu MyBB:1.6.x
adres forum:localhost
na czym polega problem (screen, opis, komunikaty, nazwa stylu/theme/szablonu):

Czy jest jakis sposob aby poprawic wyswietlania napisu "nie pamietam hasla" zaznaczone na obrazku? :

[Obrazek: 26708804.png]

Moze ktos podpowie jak to zrobic ? I jeszcze ten napis Undefine mnie niepokoi. Nie rozumiem dlaczego tak to wyglada.
TaniDedyk.pl
To jest w ACP > Style i szablony > szablony > twój styl > Nagłówek > header_welcomeblock_guest
Może wystarczy dodać w odpowiednim miejscu
Kod:
<br />
I tutaj możesz też zmienić sobie ten napis na "zapamiętaj".


Pozdrawiam!
Nic to nie dalo. Mozesz powiesz dokladnie gdzie mam to wstawic?
Pokaż jak wygląda ten kod.


Pozdrawiam!
Dobra udalo mi sie dac ten br jakos gdzies bo ogolnie to kod w tym header_welcomeblock_guest to script.

Co do Undefine to nie moge znalezc plik zrodlowy w ktorym moglbym to zmienic. A kod wyglada tak:

Kod:
<div class="upper_panel">
    <span class="float_right"><a href="{$mybb->settings['bburl']}/search.php" class="search">{$lang->toplinks_search}</a><a href="{$mybb->settings['bburl']}/memberlist.php" class="memberlist">{$lang->toplinks_memberlist}</a><a href="{$mybb->settings['bburl']}/calendar.php" class="calendar">{$lang->toplinks_calendar}</a><a href="{$mybb->settings['bburl']}/misc.php?action=help" class="help">{$lang->toplinks_help}</a></span>
<script type="text/javascript">
<!--
    lang.username = "{$lang->login_username}";
    lang.password = "{$lang->login_password}";
    lang.login = "{$lang->login}";
    lang.lost_password = " <br /><a href=\"{$mybb->settings['bburl']}/member.php?action=lostpw\" class=\"login\">{$lang->lost_password}<\/a>";
    lang.register_url = "<a href=\"{$mybb->settings['bburl']}/member.php?action=register\" class=\"register\">{$lang->welcome_register}<\/a>";
// -->
</script>
<span id="quick_login">{$lang->welcome_guest} <a href="{$mybb->settings['bburl']}/member.php?action=login" onclick="MyBB.quickLogin(); return false;" class="login">{$lang->welcome_login}</a><a href="{$mybb->settings['bburl']}/member.php?action=register" class="register">{$lang->welcome_register}</a></span>
</div>

Ten BR umiescilem w lang.lost_password.
Nie mam pojecia ktory plik jest odpowiedzialny za ten Undefine
ACP--->Szablony--->Nawigacja--->header_welcomeblock_guest...

zamień cały wpis na TO :

Kod:
<script type="text/javascript">
<!--
    lang.username = "{$lang->login_username}";
    lang.password = "{$lang->login_password}";
    lang.login = "{$lang->login}";
    lang.lost_password = " &mdash; <a href=\"{$mybb->settings['bburl']}/member.php?action=lostpw\">{$lang->lost_password}<\/a>";
    lang.register_url = " &mdash; <a href=\"{$mybb->settings['bburl']}/member.php?action=register\">{$lang->welcome_register}<\/a>";
    lang.remember_me = "{$lang->remember_me}";
// -->
</script>

<span id="quick_login">{$lang->welcome_guest} (<a href="{$mybb->settings['bburl']}/member.php?action=login" onclick="MyBB.quickLogin(); return false;">{$lang->welcome_login}</a> &mdash; <a href="{$mybb->settings['bburl']}/member.php?action=register">{$lang->welcome_register}</a>)</span>


...powinno się sprawdzić.
Nie poprawilo sie, pokazywaly sie kreski jakies tak jak na obrazku:

[Obrazek: komunikatq.png]
A dodaj takie coś w szablonie header_welcomeblock_guest:
Kod:
<script type="text/javascript">
<!--
    lang.username = "{$lang->login_username}";
    lang.password = "{$lang->login_password}";
    lang.login = "{$lang->login}";
    lang.lost_password = " <br /> <a href=\"{$mybb->settings['bburl']}/member.php?action=lostpw\">{$lang->lost_password}<\/a>";
    lang.register_url = " &mdash; <a href=\"{$mybb->settings['bburl']}/member.php?action=register\">{$lang->welcome_register}<\/a>";
    lang.remember_me = "{$lang->remember_me}";
// -->
</script>
<span style="float: right;">{$lang->welcome_current_time}</span>
        <span id="quick_login">{$lang->welcome_guest} (<a href="{$mybb->settings['bburl']}/member.php?action=login" onclick="MyBB.quickLogin(); return false;">{$lang->welcome_login}</a> &mdash; <a href="{$mybb->settings['bburl']}/member.php?action=register">{$lang->welcome_register}</a>)</span>
Tutaj tez to samo, w pliku global.lang brakowalo fragmentu kodu:
Kod:
$l['remember_me'] = "Zapamietaj";

Ten kto zrobil translation dla polskiego mybb musial to przez przypadek wyciac i jeszcze w sprawie editora dlatego byly takie bledy i w editorze i tutaj w boxie logowan.
Kolego pobierz sobie spolszczenie i sprawdź sobie frazy bo wszystko jest poprawne i nie ma żadnych błędów.
(25.03.2011, 09:43)kych0 napisał(a): Kolego pobierz sobie spolszczenie i sprawdź sobie frazy bo wszystko jest poprawne i nie ma żadnych błędów.

Kolego spolszczenie pobralem ze strony mybb.com wiec blad na pewno nie jest z mojej strony. ; )


Użytkownicy przeglądający ten wątek:

1 gości