Nest

Styl Rozszerzenie headera = pasek u dołu do przewijania forum

Założony przez Trufelek.

wersja skryptu MyBB: 1.6
adres forum: kubag.ugu.pl
na czym polega problem (screen, opis, komunikaty, nazwa stylu/theme/szablonu): Po wpisaniu kodu do global.css
Kod:
body {
  margin:  0;
  padding: 0;
}
Na dole strony w przeglądarce wyświetla się taki pasek do przesuwania forum w prawą i lewą stronę.. jak to wyłączyć ??

Wszystko możemy zobaczyć na http://kubag.ugu.pl/
W global.css dodaj do klasy body następującą wartość:
Kod:
overflow-x: hidden;
Powinno pomóc ;)
:: Akcja DZIĘKUJĘ ZA POMOC ::
Pomocy udzielam jedynie na forum. Wszystkie rzeczy wykraczające poza tą dziedzinę wykonuję odpłatnie.
Podziękowali: Trufelek
Tak to usunęło ten pasek.. ale czy da się to w ogóle jakoś zastopować... jeśli naciśniemy kółkiem myszy to i tak możemy przesuwać forum na boki ;/
Podaj thead, trow1, trow2 i tcat z globala.
:: Akcja DZIĘKUJĘ ZA POMOC ::
Pomocy udzielam jedynie na forum. Wszystkie rzeczy wykraczające poza tą dziedzinę wykonuję odpłatnie.
Kod:
.thead {
    background: #1D3652 url(images/emasters/thead_bg.gif) top left repeat-x;
    color: #ffffff;
    height: 38px;
    -webkit-border-top-right-radius: 10px;
    -webkit-border-top-left-radius: 10px;
    -khtml-border-radius-topright: 10px;
    -khtml-border-radius-topleft: 10px;
    -moz-border-radius-topright: 10px;
    -moz-border-radius-topleft: 10px;
    border-top-right-radius: 10px
    border-top-left-radius: 10px;
}
Kod:
.tcat {
    background: url(images/emasters/tcat.png);
    color: #000000;
    font-size: 12px;
}
Kod:
.trow1 {
    background: #ECECEC;
}

.trow2 {
    background: #F6F6F6;
}
Chyba wiem już o co chodzi. Przeglądając swój styl zdałem sobie sprawę, że marginesy i odstępy nie są ustawione w body, tylko w containerze.

Usuń z body linijki:
Kod:
    margin: 0;
    padding: 0;
i zamiast tego w klasie container, ustaw margin i padding na 0px.

Ewentualnie zostaw body jak jest i usuń informacje o marginesach i paddingu z containera.
:: Akcja DZIĘKUJĘ ZA POMOC ::
Pomocy udzielam jedynie na forum. Wszystkie rzeczy wykraczające poza tą dziedzinę wykonuję odpłatnie.
Dodałem to w container lecz header wyglądał tak jak wyglądał kiedyś...
Ustaw w klasie headera marginesy/padding o wartości negatywnej. Nie mam innych pomysłów :D

@edit
I upewnij się, że w klasie container nie masz czegoś w stylu:
Kod:
width: 95%
Jeśli tak, to zamień na 100% :)
:: Akcja DZIĘKUJĘ ZA POMOC ::
Pomocy udzielam jedynie na forum. Wszystkie rzeczy wykraczające poza tą dziedzinę wykonuję odpłatnie.
Zrób zdjęcie tego paska i je tutaj wrzuć, bo u mnie wszystko wyświetla się prawidłowo.
(21.01.2011, 21:09)solid23 napisał(a): Zrób zdjęcie tego paska i je tutaj wrzuć, bo u mnie wszystko wyświetla się prawidłowo.
Mniemam, że chodzi o te małe białe odstępy od prawej i lewej strony. :)
http://i54.tinypic.com/whim9d.png
:: Akcja DZIĘKUJĘ ZA POMOC ::
Pomocy udzielam jedynie na forum. Wszystkie rzeczy wykraczające poza tą dziedzinę wykonuję odpłatnie.
(21.01.2011, 20:59)Nidrax napisał(a): Ustaw w klasie headera marginesy/padding o wartości negatywnej. Nie mam innych pomysłów :D

@edit
I upewnij się, że w klasie container nie masz czegoś w stylu:
Kod:
width: 95%
Jeśli tak, to zamień na 100% :)

Nie nie mam, jedynie dodanie margin: 0; i padding: 0; zadziałało tylko w "body"
#container {
background: #ffffff;
width: 99%;
color: #000000;
border-top: none;
margin: auto auto;
padding: 10px;
text-align: left;
-moz-border-radius-bottomleft: 10px;
-moz-border-radius-bottomright: 10px;
-webkit-border-bottom-left-radius: 10px;
-webkit-border-bottom-right-radius: 10px;
}
To mój container.. od razu dodam że zmiana width na 100% zmienia tylko szerokość forum nie headeru... zmiana margin co jest i padding też nic nie dało.
Nie masz żadnych marginesów w klasie header, jak zakładam.
Spróbuj kombinacji
Marginesy i padding body na 0;
usuń z containera linijkę:
Kod:
padding: 10px;

Po prostu sądzę, że kiedy ustawiłeś margin i padding body na 0, to gryzie się w jakiś sposób z containerem, który na siłę chce dodać dodatkowy margines, który rozciąga forum. Przynajmniej z czymś podobnym spotkałem się podczas ustawiania obrazka na mojej stronie.
:: Akcja DZIĘKUJĘ ZA POMOC ::
Pomocy udzielam jedynie na forum. Wszystkie rzeczy wykraczające poza tą dziedzinę wykonuję odpłatnie.
Podziękowali: Trufelek
Dobra nie działa ; // Ale poleci pomógł za to że pomagałeś ^^ ... Potem się coś popracuje nad tym bo teraz szlaban na kompa ;/

Podobne wątki

Inne Zbyt długi pasek prywatnych wiadomości

Wczoraj, 20:06
Ostatni post: pat277

Szukam Jak przenieść pasek z panelem użytkownika

30.09.2016, 16:51
Ostatni post: olikdel

Błąd Pasek Kategorii

18.09.2016, 12:05
Ostatni post: Divir

Inne Wygląd Headera

03.05.2016, 17:03
Ostatni post: SLRH

Błąd Problem ze statystykami u dołu

30.04.2016, 14:05
Ostatni post: Divir

Skocz do:

Użytkownicy przeglądający ten wątek:

1 gości