Nest

Przerwa w forum po prawej stronie

Założony przez Tidus.

Witam. Mam taki oto problem że na moim forum podczas przeglądania jakiegoś tematu jest przerwa po prawej stronie. Zaraz dam linki. Przerwe łatwo zauważycie ,ponieważ logo jest stałej szerokości ,a forum podczas przeglądania postów nie :(

Linki :
-Strona główna : http://enjoy.xaa.pl/
-Przeglądanie postów : http://www.enjoy.xaa.pl/showthread.php?t...678#pid678

Na pewno znajdziecie tą przerwę...

Proszę o pomoc w usunięciu tego bugu :)
Kilka wątków niżej https://mybboard.pl/watek-przerwa-nad-lo...swietlanie
Czyli mam zmienić kodowanie wszystkim plików językowych na UTF-8 ? Ja sobie tak myślę że to nie jest wina kodowania ,a jakiegoś szablonu ,ponieważ w stylu standartowym wszysko działa ja trzeba...
Zrób tak jak tam pisze, jeżeli nie za działa będziemy myśleć dalej.
Walę kulą w płot, ale niech tam. Wywal CSS wtyczki Hidetags (jeśli taką masz) i powiedz co się dzieje.

EDIT: Jak to nie pomoże, to spróbuj dodać do global.css, do body:
Kod:
body {
margin-top: 8px !important;
}
8px to jest wartość taka, jaką masz na stronie głównej.
Zrobiłem tak jak napisałeś ,niestety nic to nie dało :/

Nie używam pluginu hidetags. Moje pluginy to :
- Advanced Quick Reply Form (1.0.3)
- ustrojstwo zwane : Image Resizer & Optimizer with GD (1.1)
- thx zmodyfikowane na piffka
- Modnotive (1.2.2)
- Polish IMs (1.2.2) (na razie jest dezaktywowany bo muszę się dowiedzieć jak dodać te pola w profilu ...)
- Usergroup legends (2.0)
- Board Message (2.0.0)
- SpiceFuse Shoutbox (1.1 Beta 1)


I to też nie jest wina pluginów ponieważ na stylu domyślym z włączanymi pluginami tego błędu nie ma. Używam Stylu GMMO ,który pochodził z GMMO. Na GMMO działał poprawnie bez tej szpary jednak na enjoy coś jest z nim nie tak :/

Poprzez export jakiś szablon się zmienił i pewnie z tego ten bug.... Tylko jak nazywa się szablon odpowiedzialny za widok tematu (czyli czytania postów) wtedy skopiowałbym go z domyślnego do plusa i może by się udało :)

Czekam na odpowiedź.
Wydaje mi się, że to nie wina szablonu, bo tam nie bardzo ma się co zepsuć. Wpisz w body:
Kod:
body {
margin: 0 0 0 0;
}

Jak to nie zadziała (Uwaga! Nie będzie ani marginesu dolnego ani górnego - przynajmniej powinno... Prawdopodobnie dolny będzie ustawiony tak jak był, jeżeli jest to w innej klasie ustawione, czyli idąc tym tokiem górny też może nie działać, ale i tak to zrób), to zaczniemy grzebać w szablonach.
Nie to dalej nie jest to :-/

Czas się zabrać za szablony. To który jest odpowiedzialny za wygląd tematów ?
(28.07.2009, 19:25)Tidus napisał(a): Nie to dalej nie jest to :-/

Czas się zabrać za szablony. To który jest odpowiedzialny za wygląd tematów ?

showthread... Ale IMHO to na 95% nie jest wina szablonu. Prawdopodobnie nawet go nie importowałeś. Proponowałbym tak - wyłącz wszystkie wtyczki i przełącz się na domyślny styl (zrób to na localhoście najlepiej). Następnie włączaj jedną, sprawdzaj forum (odśwież dwa razy i przykładowy wątek i stronę główną!) i jeżeli to 'coś' się pojawi, no to masz winowajcę. Ja wtedy oblukam mniej więcej co ona modyfikuje i postaram się pomóc. A jak żadna nie będzie tego powodować... no to nie mam tęczowego pojęcia.
Ja już chyba wiem co to powoduje tą szparę. Logo. Mam logo na 900 px szerokośc - czyli taką szerokość jak jest na stronie głównej. I na stronie głównej jest dobrze. Tylko w oglądaniu tematu szerokość forum spada (nie wiem co to powoduje :/) ,logo swojej nie zmieni i w skutek tego powstaje ta szpara.

Trochę głupi bug... Ale teraz już przynajmniej wiemy co mamy zwalczyć :)
Innymi słowy trzebabyło by narzuciś MyBB jakąś stałą szerokość ,której zmiena byłaby zakazana przez jakiś artybut mybb.

Znacie na to kod ? Szerokość mojego forum to 900px :)
No to spróbuj:
Kod:
.logo {
width: 860px !important;
}

Ale Twoja teoria jest IMO bez sensu... Zrób jednak to co napisałem i przede wszystkim wywal tło z klasy .logo, bo skoro go nie ma, no to po co ma się tam poniewierać? I przeskaluj/przytnij logo do takich wymiarów jak napisałem, tj. 860px.

Podobne wątki

Inne Statystyki Po prawej stronie [kod]

17.04.2016, 15:37
Ostatni post: DarkNever

Inne Carbon tabelka po prawej stronie ustawienie pionowe tekstu.

28.03.2016, 20:57
Ostatni post: Benek999

Belka na dole zamiast po prawej stronie

03.01.2016, 15:26
Ostatni post: myCreedo

Inne Nick autora ostatniego postu po prawej

28.12.2015, 17:57
Ostatni post: nahajek

Szukam Statystyki z prawej strony forum

19.11.2015, 01:23
Ostatni post: MaciejB

Skocz do:

Użytkownicy przeglądający ten wątek:

1 gości