Nest

Opis posta - brak buttonów

Założony przez decybel1000.

Kilka szczegółów o moim forum i stylu, z którym mam problem:
nazwa stylu:blackinci-3
wersja skryptu MyBB:1.4
adres forum:www.forum-ostroda.info
opis problemu:

Witam, zainstalowałem sobie nowy styl, podogrywałem co trzeba i nagle zauważyłem że brakuje mi buttonów w postach. Tzn mam tylko edycja i delete.

Powinno być jeszcze www, podziękuj oraz status gg, ale nie ma.
Co chodzi o wyświetlanie gg to nawet zainstalowałem wtyczkę jeszcze raz, niestety to nie pomogło.

Przekopiowałem kody postbit z default do nowego stylu, niestety to też nie pomogło.


Kod wygląda tak:

Kod:
{$ignore_bit}
<a name="pid{$post['pid']}" id="pid{$post['pid']}"></a>
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder" style="{$post_extra_style} {$post_visibility}" id="post_{$post['pid']}">
    <tbody>
        <tr>
            <td class="tcat">
                <div class="float_left smalltext">
                    {$post['postdate']}, {$post['posttime']} <span id="edited_by_{$post['pid']}">{$post['editedmsg']}</span>
                </div>
                {$post['posturl']}
            </td>
        </tr>

        <tr>
            <td class="trow1 {$unapproved_shade}">
                <table cellspacing="0" cellpadding="0" border="0" style="width: 100%;">
                    <tr>
                        <td class="post_avatar" width="1" style="{$post['avatar_padding']}">
                            {$post['useravatar']}
                        </td>
                        <td class="post_author">
                            <strong><span class="largetext">{$post['profilelink']}</span></strong> {$post['onlinestatus']}<br />
                            <span class="smalltext">
                                {$post['usertitle']}<br />
                                {$post['userstars']}
                                {$post['groupimage']}
{$post['groupimage']}

                                   </span>
                        </td>
                        <td class="smalltext post_author_info" width="165">
                            {$post['user_details']}
                        </td>
                    </tr>
                </table>
            </td>
        </tr>

        <tr>
            <td class="trow2 post_content {$unapproved_shade}">
                <span class="smalltext"><strong>{$post['icon']}{$post['subject']} {$post['subject_extra']}</strong></span>

                <div class="post_body" id="pid_{$post['pid']}">
                    {$post['message']}
                </div>
                {$post['attachments']}
                {$post['signature']}

                <div class="post_meta" id="post_meta_{$post['pid']}">
                {$post['iplogged']}
                </div>
            </td>
        </tr>

        <tr>
            <td class="trow1 post_buttons {$unapproved_shade}">
                <div class="author_buttons float_left">
                    <a href="gg:{$post['sr_gadu']}"><img src="http://status.gadu-gadu.pl/users/status.asp?id={$post['sr_gadu']}&styl=0" /></a>
<a href="http://ludzie.tlen.pl/{$post['sr_tlen']}/" target="_blank"><img src="http://status.tlen.pl/?u={$post['sr_tlen']}&t=1" /></a>
<a href="skype:{$post['sr_skype']}?chat"><img src="http://mystatus.skype.com/smallicon/{$post['sr_skype']}" /></a>
{$post['button_email']}{$post['button_pm']}{$post['button_www']}{$post['button_find']}
                </div>
                <div class="post_management_buttons float_right">{$post['button_edit']}{$post['button_quickdelete']}{$post['button_quote']}{$post['thanks']}{$post['button_multiquote']}{$post['button_report']}{$post['button_warn']}{$post['button_reply_pm']}{$post['button_replyall_pm']}{$post['button_forward_pm']}{$post['button_delete_pm']}
                </div>
            </td>
        </tr>
    <table>{$post['thxdsp']}</table></tbody>
</table>{$post['adsaf']}{$post['adsaf']}{$post['adsaf']}{$post['adsaf']}{$post['adsaf']}

Ktoś pomoże ?

Pozdrawiam.
A jak wrzucisz taki:
http://www.wklej.org/id/357756/
kych0 po podmienieniu kodu nie widać żadnych zmian :(
A wrzuciłeś te obrazki do images/polish lub images/nazwa_stylu/polish ?
bo z tego co widze to nie bardzo.
Tak buttony są wgrane tam gdzie powinny byc i na poprzednim stylu wszystko smigalo, w tej chwili wygląda to tak.

http://iv.pl/images/82366772609754339884.jpg

Jakby nie było buttonów to by wyświetlał się tekst np edytuj czy coś a nawet testu ne ma.

Tam gdzie jest teraz button www też był sam napis ale grzebałem gdzieś i wyświetliło grafike, tylko teraz nawet nie pamiętam gdzie :(


Tak sobie patrze w szablony i mam pytanie ... czy możlwe że za te buttony odpowiada inna tempelka np. postbit_edit ;] ??
A takie cos:
Kod:
{$ignore_bit}
<a name="pid{$post['pid']}" id="pid{$post['pid']}"></a>
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder" style="{$post_extra_style} {$post_visibility}" id="post_{$post['pid']}">
    <tbody>
        <tr>
            <td class="tcat">
                <div class="float_left smalltext">
                    {$post['postdate']}, {$post['posttime']} <span id="edited_by_{$post['pid']}">{$post['editedmsg']}</span>
                </div>
                {$post['posturl']}
            </td>
        </tr>

        <tr>
            <td class="trow1 {$unapproved_shade}">
                <table cellspacing="0" cellpadding="0" border="0" style="width: 100%;">
                    <tr>
                        <td class="post_avatar" width="1" style="{$post['avatar_padding']}">
                            {$post['useravatar']}
                        </td>
                        <td class="post_author">
                            <strong><span class="largetext">{$post['profilelink']}</span></strong> {$post['onlinestatus']}<br />
                            <span class="smalltext">
                                {$post['usertitle']}<br />
                                {$post['userstars']}
                                {$post['groupimage']}
                            </span>
                        </td>
                        <td class="smalltext post_author_info" width="165">
                            {$post['user_details']}
                        </td>
                    </tr>
                </table>
            </td>
        </tr>

        <tr>
            <td class="trow2 post_content {$unapproved_shade}">
                <span class="smalltext"><strong>{$post['icon']}{$post['subject']} {$post['subject_extra']}</strong></span>

                <div class="post_body" id="pid_{$post['pid']}">
                    {$post['message']}
                </div>
                {$post['attachments']}
                {$post['signature']}

                <div class="post_meta" id="post_meta_{$post['pid']}">
                {$post['iplogged']}
                </div>
            </td>
        </tr>

        <tr>
            <td class="trow1 post_buttons {$unapproved_shade}">
                <div class="author_buttons float_left">
{$post['button_email']}{$post['button_pm']}{$post['button_www']}{$post['button_find']}
                </div>
                <div class="post_management_buttons float_right">{$post['button_tyl']}{$post['button_edit']}{$post['button_quickdelete']}{$post['button_multiquote']}{$post['button_report']}{$post['button_warn']}{$post['button_reply_pm']}{$post['button_replyall_pm']}{$post['button_forward_pm']}{$post['button_delete_pm']}
                </div>
            </td>
        </tr>
        <tr style="{$post['tyl_display']};" id="tyl_{$post['pid']}">
        </tr>
    </tbody>
</table>
Też nie działa, zaobserwowałem coś bardzo dziwnego tylko nie wiem za bardzo co to oznacza, może to że nie można nadpisać tego szablonu ??

Wygląda to tak:

http://iv.pl/images/14257850269555332755.jpg
Czy do "przerzutki" kodu używasz jakiegoś edytora tekstu?
Jakiej przeglądarki internetowej używasz?
Używam firefoxa, pamietam jak kiedys edytowałem global css to też sie nie dało bo zły atrybut był w pliku gdzie się to mieściło. Po zmianie atrybudu dało się już to edytować.

Tylko pytanie, w jakim pliku są zapisane te szablony, i czy możliwym jest to żeby atrybut był zmieniony na niezapisywalny.

Z innymi szablonami nie mam problemu, moge je edytować i wszystko działa jak należy.

Edytuje je poprzez panel.

Istnieje jakaś inna możliwość edycji hmm ... ??
Poprzez phpmy admin udało mi się podmienić zawartość postbit ;)

Dalej nie widać zmian na forum.

Ocb ;>??
Problem polega na tym że ten styl nie ma zdefiniowanych tych przycisków poprostu.
A więc co można zrobić w takim przypadku ;>??
skopiować CSS'a showthread.css ze stylu na którym te przyciski działały na styl na którym nie działają. Wtedy działanie tych przycisków się przywróci, gdyż w tamtym CSS'ie który skopiowaliśmy były wgrane te przyciski. :lol: Pozdrawiam!!!

Podobne wątki

Błąd Nie równo pokazuje opis dzialu

20.11.2016, 14:23
Ostatni post: Snake_

Jak zrobić w podziałach coś takiego? ( OPIS )

10.10.2016, 11:59
Ostatni post: Conors

Styl Opis działu - prostokąt który nie pasuje

25.09.2016, 20:24
Ostatni post: Winchester

Szukam Opis forum pod nazwą forum (działy/forum)

21.06.2016, 18:42
Ostatni post: Ardex

Buttony Zaokrąglenie buttonów moderacyjnych

29.04.2016, 15:44
Ostatni post: myCreedo

Skocz do:

Użytkownicy przeglądający ten wątek:

1 gości