Od 2008. wsparcie już tylko dla PHP5

Założony przez DamYan.

Jak poinformował Chris Boulton (http://community.mybboard.net/showthread.php?tid=25674) - wersje MyBB wychodzące od lutego 2008 będą zoptymalizowane do użytkowania ich na serwerach z obsługą co najmniej PHP 5.2 (i wyższe), a co za tym idzie - hostingi, które jeszcze nie dokonały upgrade'u do najnowszych wersji PHP - mogą mieć kłopoty z obsługą naszych forów.
Jak pisze Chris PHP5 umożliwia przyspieszenie działania forum jeszcze bardziej oraz daje dużo większe pole manewru dla developerów, czego nie można było wykorzystać przy tworzeniu kodu kompatybilnego z PHP4.
Jeśli zaś chodzi o bazę MySQL - wymagania pozostają bez zmian, jednakże zalecane będzie używanie jej w wersji 5.1.
Tu trochę odetchnąłem, gdyż mój hosting póki co używa wersji 4.1 ;) Zatem zadbajcie zawczasu o odpowiedni hosting - do lutego jeszcze chwila jest ;)
To mogę się cieszyć bo moje serwery są na php 5 :D

Osobiście uważam, że to bardzo dobre posunięcie ze strony twórców mybb.
Możemy sie cieszyć, że mamy tak dobre forum, kompatybilne z najnowszymi standardami
a mnie to nie dotyczy ja już jestem na PHP5 (hura hura :D)

trzeba korzystać z nowszych standardów .
Chris dopisał:
Cytat:MyBB 1.4, our upcoming feature release, will work correctly with PHP 4. Maintenance releases such as MyBB 1.4.1, 1.4.2 etc will also work correctly with PHP 4.

All new feature releases after February 2008 will support PHP 5.0 onwards.
Wygląda na to, że wersja 1.4 skryptu puka do drzwi :cool:, skoro Chris tak mocno podkreśla datę lusty 2008 i późniejsze wydania :)
Wg mnie - tylko się cieszyć!
Kurcze.. bede musiał chyba pogonić mojego admina, żeby upgrade zrobili... bo jak narazie, to ja mam PHP 4.4.7, a MYSQL - 4.1.22 :/
Bo jeszcze troche, i przestaną php4 obsługiwać...
już dawno powinno tak być ;]
marines napisał(a):już dawno powinno tak być ;]

Biorąc pod uwagę, mimo wszystko, prężny rozwój i chęć bycia kompatybilnym nie tylko w górę ;) - to i tak nieźle, że developerzy zdecydowali się na taki krok. Jak widać nie wszystkie hostingi oferują zarówno MySQL, jak i PHP w wersjach 5+.
A jak się zachowuje forum podczas podmianki MYSQL 4.1 - 5.0??
Lordnever napisał(a):A jak się zachowuje forum podczas podmianki MYSQL 4.1 - 5.0??

Możesz zapytać bardziej szczegółowo? :)
Ja nie zauważyłem zmian, niedawno była u mnie upgrade MySQL'a, i forum działa tak samo.

Podobne wątki

Tłumaczenie do MyBB 1.8 już dostępne!

08.09.2014, 20:41
Ostatni post: szulcu

Pierwsza BETA MyBB 1.8 już dostępna!

04.06.2014, 01:43
Ostatni post: DamYan

Polskie tłumaczenie dla MyBB 1.6.13 już gotowe

26.04.2014, 16:50
Ostatni post: szulcu

Tłumaczenie do wersji 1.6.10 już jest dostępne do pobrania

29.04.2013, 16:13
Ostatni post: szulcu

MyBB 1.8 - wsparcie dla Gravatar, więcej informacji w ACP

21.08.2012, 11:55
Ostatni post: Łukasz Tkacz

Skocz do:

Użytkownicy przeglądający ten wątek:

1 gości