Nest

MyBB 1.4.13 Released – Security Patches to MyBB 1.4.12

Założony przez zapal.

Cytat:MyBB 1.4.13 is now available on the MyBB website and is a patch to MyBB 1.4.12 which introduced two regressions related to the security updates in MyBB 1.4.12.

This release is to ensure that all users on 1.4.12 have the proper security patches applied to their forum.

Thank you to Pirata Nervo and Labrocca for alerting us of these issues and to Stefan Esser for assisting us in a patch for Issue #843.

What’s fixed in this version?
Issue #880
Issue #843
This update does not require running the upgrader.
There are no database schema, language string, or template changes in this version.

MyBB 1.4.12 to MyBB 1.4.13 Patch
This patch is only for users running MyBB 1.4.12. If you are running an older version of MyBB then please download MyBB 1.4.13 from the MyBB site and update to it using the general [Wiki: Upgrading] guide.

Please download the attached ZIP archive and replace the files in your forum directory with those from the ZIP archive.
changed_files_1413.zip

Alternatively, if you are running MyBB 1.4.11, you may follow the “MyBB 1.4.11 to MyBB 1.4.12 Patch” instructions in the MyBB 1.4.12 announcement and then apply the MyBB 1.4.12 to MyBB 1.4.13 patch above.

The following files were changed since the initial MyBB 1.4.12 release:
inc
datahandlers
post.php
functions.php
class_core.php
* Red represents files that contain security updates
* Green represents new files added in this release

Reporting MyBB security vulnerabilities
If you think you’ve found a vulnerability in MyBB, we advise you not to publicly post it on these forums or publicly release information about it elsewhere until we’ve had time to prepare and release a patch.

As always, you can send through security related messages on the MyBB website from the Contact Us page.

ja juz zaktualizowalem , w sumie do podmiany 3 pliki...
A czy gdy mam functions.php z google seo to też muszę podmieniać i ręcznie go edytować?
PS. pobrany z załącznika posta DamYana.
(19.04.2010, 13:52)XemiX napisał(a): A czy gdy mam functions.php z google seo to też muszę podmieniać i ręcznie go edytować?
PS. pobrany z załącznika posta DamYana.

Weź sobie zainstaluj program winmerge, wrzuć sobie te 2 pliki do tego programu.

On Ci porówna linie i będziesz wiedział, co gdzie pozmieniać :)
Xemix, odsyłam do tego wątku. Udostępniłem tam plik functions.php, lecz nie wiem, czy działa, bo nie testowałem.

=-Po testach-=
Wydaje mi się, że wszystko w porządku. Bez problemu dodałem regułki do .htaccess i mogę normalnie wchodzić w działy i tworzyć wątki, które mają poprawne linki. Jednak prosiłbym każdego, aby był ostrożny, bo nie mam pewności. :P (obawiam się złośliwości rzeczy martwych)
Jeżeli komuś działa - proszę o kliknięcie w pomógł.

Powód edycji - chaos, którego trudno zrozumieć. :P
dobra, tutaj też to napiszę
autorzy pluginu Goolgle-SEO dają dostęp ( read-only ) do swojego repo
http://github.com/frostschutz/Google-SEO
stąd można pobrać zarówno functions.php, jak i całość, dla każdego MyBB, dla którego taka paczka powstała ... czy raczej dla którego taki tag powstał ;)
Czy może ktoś udostępnić te trzy pliki do aktualizacji z 1.4.12 na 1.4.13?
Znajdziesz je pod linkiem: http://mybboard.net/download/120

Wrzucam też jako załącznik.


Załączone pliki
.zip   changed_files_1413.zip (Rozmiar: 45,98 KB / Pobrań: 47)

Skocz do:

Użytkownicy przeglądający ten wątek:

1 gości