Kilka szczegółów o moim forum i stylu, z którym mam problem:
nazwa stylu: MyAqua
wersja skryptu MyBB: 1.4.9
adres forum: melivi.cba.pl
opis problemu:

Witam.
Zająłem się przeróbką motywu 'myAqua' pod MyBB 1.4.x
Napotkałem na problem rozpadającego się panelu w poście.
Na screenie widać to dokładnie.
1. to Mozilla Firefox a 2. to Internet Explorer (co do opery nie wiem gdyż nie posiadam i nie sprawdzałem)
[Obrazek: 14j15c5.jpg]

Motyw można pobrać stąd:
http://www.zynge.net/thread-myaqua

Moja strona na której zajmuję się wszelka pracą i przeróbkami nad tym motywem: melivi.cba.pl

W sumie wolał bym to przerobić na taki układ (standardowy):
[Obrazek: amulg3.jpg]

Za wszelką pomoc mogę w ramach odwdzięczenia pomóc w grafice itp.
Trochę sobie poradziłem. Edytowałem .xml'a

Wygląd początkowy:
Kod:
<tr>
<td class="pb" valign="top" style="white-space: nowrap; text-align: center;">
<fieldset style="margin: 0pt auto;">
<legend align="left">
<a href="#" id="profilelink_{$post['pid']}">{$post['username_formatted']}</a>
{$post['onlinestatus']}
<div id="profilelink_{$post['pid']}_popup" class="popup_menu" style="display: none;">
<div class="popup_item_container">
<a href="{$mybb->settings['bburl']}/member.php?action=profile&amp;uid={$post['uid']}" class="popup_item">View User Public Profile</a>
</div>
<div class="popup_item_container">
<a href="{$mybb->settings['bburl']}/search.php?action=finduser&amp;uid={$post['uid']}" class="popup_item">View All Posts Made By User</a>
</div>
<div class="popup_item_container">
<a href="{$mybb->settings['bburl']}/search.php?action=finduserthreads&uid={$post['uid']}" class="popup_item">View All Threads Made By User</a>
</div>
</div>
<script language="javascript" type="text/javascript">
new PopupMenu("profilelink_{$post['pid']}");
</script>
</legend>
<div style="clear: both;"></div>
<div id="avatar" style="display: inline;">
<align="left">{$post['useravatar']}</align>
</div>
<div id="gimg">
<align="right">
{$post['groupimage']}
</align>
</div>
<div id="pbimg">
<align="right">
<a href="{$post['website']}" target="_blank"><img src="images/myaqua/postbit/website.png" width="90px" title="website"></a><br>
<a href="private.php?action=send&amp;uid={$post['uid']}"><img src="images/myaqua/postbit/pm.png" alt="{$lang->postbit_pm}"  width="90px" title="{$lang->postbit_pm}" /></a><br>
<a href="member.php?action=emailuser&amp;uid={$post['uid']}"><img src="images/myaqua/postbit/email.png" alt="{$lang->postbit_email}" title="{$lang->postbit_email}" width="90px" /></a><br>
</align>
</div>
<div style="margin-bottom: 5px;"></div>
<!-- start: user_details -->
<span class="smalltext">
            {$post['user_details']}
</span>
<!-- end: user_details -->
</span>
</fieldset>

i

Kod:
<template name="postbit_avatar" version="1406"><![CDATA[<a href="{$post['profilelink_plain']}"><img src="{$post['avatar']}" alt="" width="80px" height="80px" ALIGN="LEFT" /></a>]]></template>

Zmieniłem na:

Kod:
<td class="pb" valign="top" style="white-space: nowrap; text-align: center;">
<fieldset style="margin: 0pt auto;">
<legend align="center">
<a href="#" id="profilelink_{$post['pid']}">{$post['username_formatted']}</a>
{$post['onlinestatus']}
<div id="profilelink_{$post['pid']}_popup" class="popup_menu" style="display: none;">
<div class="popup_item_container">
<a href="{$mybb->settings['bburl']}/member.php?action=profile&amp;uid={$post['uid']}" class="popup_item">Zobacz profil użytkownika</a>
</div>
<div class="popup_item_container">
<a href="{$mybb->settings['bburl']}/search.php?action=finduser&amp;uid={$post['uid']}" class="popup_item">Znajdź wszystkie posty użytkownika</a>
</div>
<div class="popup_item_container">
<a href="{$mybb->settings['bburl']}/search.php?action=finduserthreads&uid={$post['uid']}" class="popup_item">Pokaż tematy użytkownika</a>
</div>
</div>
<script language="javascript" type="text/javascript">
new PopupMenu("profilelink_{$post['pid']}");
</script>
</legend>
<div style="clear: both;"></div>
<div id="gimg">
<align="center">
{$post['groupimage']}
</align>
</div>
<div id="avatar" style="display: center;">
<align="center">{$post['useravatar']}</align>
</div>
<div style="margin-bottom: 5px;"></div>


</fieldset>

i

Kod:
<template name="postbit_avatar" version="1406"><![CDATA[<a href="{$post['profilelink_plain']}"><img src="{$post['avatar']}" alt="" ALIGN="center" /></a>]]></template>

Wygląda to tak:
[Obrazek: 2epmr12.jpg]

A chciał bym by wyglądało:
[Obrazek: ofx8jc.jpg]

Tu jest plik myaqua.xml
http://w880.wrzuta.pl/plik/5rWDlMGOecp/myaqua
Adrian napisał 09.11.2009, 23:54:
Poprawiłem nazwę tematu.