Mindboard2 - Problem z opisem działu

Założony przez durda.

Kilka szczegółów o moim forum i stylu, z którym mam problem:
nazwa stylu:Mindboard2
wersja skryptu MyBB:1.4.9
Styl pobrałem z : http://mybbaddons.com/board/thread-163.htmlMyBB:149
opis problemu: Problem polega na tym, że gdy napisze opis danego działu to wygląda to tak:

[Obrazek: screenjo.th.jpg]
Zaznaczenie pokazuje jak wygląda dział z opisem. Jak widać opis działu powoduje przekrzywienie się ramki i niewiem jak to naprawić.

Proszę o pomoc.
Ja bym to załatwił tak
Opis działu - Szablony -> forumbit_depth1_cat
Kod:
<td class="thead" colspan="5">
<div class="expcolimage"><img src="{$theme['imgdir']}/{$expcolimage}" id="cat_{$forum['fid']}_img" class="expander" alt="{$expaltext}" title="{$expaltext}" /></div>
<div><strong><a href="{$forum_url}">{$forum['name']}</a></strong><br /><div class="smalltext">{$forum['description']}</div></div>
</td>
Zamienił na
Kod:
<td class="thead" colspan="5">
<div class="expcolimage"><img src="{$theme['imgdir']}/{$expcolimage}" id="cat_{$forum['fid']}_img" class="expander" alt="{$expaltext}" title="{$expaltext}" /></div>
<div><strong><a href="{$forum_url}">{$forum['name']}</a></strong> | <span class="smalltext">{$forum['description']}</span></div>
</td>

nazwa i opis działu będą w jednej lini oddzielone | przez co nie powinno rozwalać układu, ale kiedy nie będzie opisu działu pewnie będzie się wyświetlał znak | :(

chyba że inny masz kod w forumbit_depth1_cat (bo nie wiem jak to w tym themie jest) to zamień <br /> na | i
Kod:
<div class="smalltext">{$forum['description']}</div>
na
<span class="smalltext">{$forum['description']}</span>
Kod w forumbit_depth1_cat wygląda tak
Kod:
<table border="0" cellpadding="0" cellspacing="0" align="center" width="100%">



<tbody>

<tr>
<td align="left"><img src="{$theme['imgdir']}/sol.gif" alt="" border="0"></td>

<td style="background: url({$theme['imgdir']}/orta.gif) repeat-x"
align="center" width="100%"><div class="expcolimage"><img
src="{$theme['imgdir']}/{$expcolimage}" id="cat_{$forum['fid']}_img"
class="expander" alt="{$expaltext}" /></div>

<div style="text-align:
left;"><strong><a
href="forumdisplay.php?fid={$forum['fid']}"><font color="white">{$forum['name']}</font></a></strong><br
/><div
class="smalltext">{$forum['description']}</div></strong></div>

</td>

<td align="right"><img src="{$theme['imgdir']}/sag.gif" alt="" border="0"></td>

</tr>

</tbody>

</table>

<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">

</thead>

<tbody style="{$expdisplay}" id="cat_{$forum['fid']}_e">

<tr>

<td class="tcat" width="35"> </td>

<td class="tcat"><strong>{$lang->forumbit_forum}</strong></td>

<td class="tcat" width="85" align="center" style="white-space:
nowrap"><strong>{$lang->forumbit_threads}</strong></td>

<td class="tcat" width="85" align="center" style="white-space:
nowrap"><strong>{$lang->forumbit_posts}</strong></td>

<td class="tcat" width="200" align="center"><strong>{$lang->forumbit_lastpost}</strong></td>

</tr>

{$sub_forums}

</tbody>

</table>

<table border="0" cellpadding="0" cellspacing="0" align="center" width="100%">


<tbody>


<tr>

<td align="left"><img src="{$theme['imgdir']}/solalt.gif" alt="" border="0" class="reflect"></td>

<td style="background: url({$theme['imgdir']}/ortalt.gif) repeat-x" align="center" width="100%">

</td>

<td align="right"><img src="{$theme['imgdir']}/sagalt.gif" alt="" border="0" class="reflect"></td>

</tr>

</tbody>

</table>

<br />
Gdy zmienię
Kod:
<div class="smalltext">{$forum['description']}</div>
na
<span class="smalltext">{$forum['description']}</span>
to opis wyświetla się w tej samej lini co nazwa dzialu
(12.10.2009, 21:48)netuser napisał(a): ...
nazwa i opis działu będą w jednej lini oddzielone | przez co nie powinno rozwalać układu, ale kiedy nie będzie opisu działu pewnie będzie się wyświetlał znak | :(
...
żeby było w 2 liniach musiał byś powiększyć obrazki, ale nie ma pewności, czy by dobże działało
Podziękowali: durda

Podobne wątki

Błąd Link miesza się z opisem

Wczoraj, 20:50
Ostatni post: Maciej Lachowicz

Styl Dodanie obrazka do nazwy działu problem

23.03.2016, 22:09
Ostatni post: ficus

Inne Poddziały pod opisem działu - jak zrobić?

31.01.2016, 16:32
Ostatni post: Ardex

Błąd Blad z opisem postu

05.12.2015, 16:49
Ostatni post: darpol12

Styl Obrazek przed opisem działu(Nie Ikona!)

26.02.2015, 23:45
Ostatni post: Razziel

Skocz do:

Użytkownicy przeglądający ten wątek:

1 gości