Nest

Inne Problem z ustawieniem searchbox.

Założony przez Trufelek.

wersja skryptu MyBB: 1.6
adres forum: http://www.kubag.cba.pl
na czym polega problem (screen, opis, komunikaty, nazwa stylu/theme/szablonu): Zacznę od kodów

Global.css
Kod:
.search_container {
    position: absolute;
    right: 0;
    bottom: 8px;
}

.searchbutton {
    position: absolute;
    top: 7px;
    left: 7px;
}

.searchbox {
    background: #033A61;
    color: white;
    border: 1px solid #027DCB;
    padding: 3px 25px;
    position: relative;
    height: 17px;
    width: 170px;

    border-radius: 5px;
    /* the same for FF&Webkit */
    -moz-border-radius: 5px;
    -webkit-border-radius: 5px;
}

Header
Kod:
<div id="pagetop">
<div class="header_left"></div>
<div class="header_right"></div>
<div class="header">
    <div id="panel">
        {$welcomeblock}
    </div>
<a href="{$mybb->settings['bburl']}/index.php">
<img src="{$theme['logo']}" alt="{$mybb->settings['bbname']}" title="{$mybb->settings['bbname']}" />
</a>

</div>
<div class="menu_left"></div>
<div class="menu_right"></div>
<div class="menu">
<li><li><li><li><li><li {$index_active}><a href="{$mybb->settings['bburl']}/index.php">Forum</a></li></li></li></li></li></li>
<li {$search_active}><a href="{$mybb->settings['bburl']}/search.php">{$lang->toplinks_search}</a></li>
<li {$members_active}><a href="{$mybb->settings['bburl']}/memberlist.php">{$lang->toplinks_memberlist}</a></li>
<li {$calendar_active}><a href="{$mybb->settings['bburl']}/calendar.php">{$lang->toplinks_calendar}</a></li>
<li {$misc_active}><a href="{$mybb->settings['bburl']}/misc.php?action=help">{$lang->toplinks_help}</a></li>
<li><a href="http://nlils-rp.ugu.pl/">>>IPB styl na sprzedaż.<<</a></li>
<div class="search_container">

                    <!-- searchbox -->
                    
                    <form method="post" action="{$mybb->settings['bburl']}/search.php">
                    <input type="hidden" name="action" value="do_search" />
                    <input type="hidden" name="postthread" value="1" />
                    <input type="hidden" name="forums" value="all" />
                    <input type="hidden" name="showresults" value="threads" />
                    <input type="text" name="keywords"
                    value="Search..." onfocus="if(this.value == 'Search...') { this.value = ''; }" onblur="if(this.value=='') { this.value='Search...'; }"
                    class="searchbox" />
                    <input type="image" src="{$theme['imgdir']}/search.png" class="searchbutton" name="submit" value="Search" />
                    </form>
    
                    <!-- searchbox -->

                </div>


</div>
</div>


    <div id="container">
        <a name="top" id="top"></a>
        <hr class="hidden" />
        <div id="content">
            {$pm_notice}
            {$bannedwarning}
            {$bbclosedwarning}
            {$unreadreports}
<navigation>
            <br />

A teraz... Moim problemem jest ustawienie searchbox.. Kod mam wklejony żeby okienko search wyświetlało się w menu lecz jak wejdziemy na moje forum wyświetla się ono na dole strony.. Jak to zmienić żeby było w menu ? i nie żeby wyglądało tak jak wygląda pod względem graficznym.
Od razu mówię że zapożyczyłem searchbox z innego stylu...

Podam ci jak ja mam a ty se to przerób na swój wygląd :)

Header:
Kod:
<a name="top" id="top"></a>


    <div id="header">
<div class="user_navigation">{$welcomeblock}        
</div>
        <div class="logo"><a href="{$mybb->settings['bburl']}/index.php"><img src="{$theme['logo']}" alt="{$mybb->settings['bbname']}" title="{$mybb->settings['bbname']}" /></a></div>
        <div class="menu">
<a href="{$mybb->settings['bburl']}/search.php" id="search_menu">{$lang->toplinks_search}</a>
<a href="{$mybb->settings['bburl']}/memberlist.php">{$lang->toplinks_memberlist}</a>
<a href="{$mybb->settings['bburl']}/calendar.php">{$lang->toplinks_calendar}</a>
<a href="{$mybb->settings['bburl']}/misc.php?action=help">{$lang->toplinks_help}</a>
<a href="{$mybb->settings['bburl']}/misc.php?action=syndication">RSS</a>
<a href="{$mybb->settings['contactlink']}">{$lang->bottomlinks_contactus}</a>
<a href="{$mybb->settings['bburl']}/index.php">Forums</a>


<div class="qsearch">
<span style="float: right; margin-top: 0px; margin-right: 40px;>


<form method="post" action="{$mybb->settings['bburl']}/search.php">

<input type="hidden" name="action" value="do_search" />
<input type="hidden" name="postthread" value="1" />
<input type="hidden" name="forums" value="all" />
<input type="hidden" name="showresults" value="threads" />
<input type="text" value="Enter Search Terms..." onclick="this.value='';" name="keywords" />
<input name="search" type="image" value="&nbsp" class="btn" style="border: none;">

</form>
</span>
</div>



    </div></div></div>


<!-- End: MyIPB Header -->

    <div id="container">
        <hr class="hidden" />
        <br class="clear" />
        <div id="content">
            {$pm_notice}
            {$bannedwarning}
            {$bbclosedwarning}
            {$unreadreports}
            <navigation>
            <br />

css:
Kod:
.qsearch {
    background: url(images/ipb/search_bg.png) top left no-repeat;
    height: 50px;
        width: 160x;
        float: right;
    padding: 0;
    margin: 0;
        border: none;
}

.qsearch input {
    background: transparent;
    color: #202020;
    border: none;
    float: left;
    font-size: 11px;
    font-family: trebuchet ms, arial;
    padding: 1px 5px 5px 5px;
        margin: 0;
    width: 127px;
}

.qsearch .btn {
    background: url(images/ipb/search_icon_off.png) no-repeat;
        border: none;
    float: right;
    margin-left: 2px;
    margin-top: 1px;
        padding: 0;
    width: 23px;
        height: 20px;
}

.qsearch .btn:hover {
    background: url(images/ipb/search_icon.png) top left no-repeat;
        border: none;
    float: right;
    margin-left: 2px;
    margin-top: 1px;
        padding: 0;
width: 23px;
height: 24px;
}

Podobne wątki

Problem z ustawieniem ikon działów.

28.09.2016, 19:37
Ostatni post: Argayn

Styl Problem z ustawieniem statsindex

08.11.2015, 20:07
Ostatni post: Kopalniok

Inne Problem z ustawieniem wyglądu.

15.03.2015, 21:02
Ostatni post: G4m3RR

Problem z ustawieniem ikony przycisku Edytuj.

11.03.2014, 21:01
Ostatni post: Snake_

Styl Problem z ustawieniem sidebox'a.

30.08.2013, 21:26
Ostatni post: Satanus

Skocz do:

Użytkownicy przeglądający ten wątek:

1 gości