Nest

Czyszczenie tabel w stylu

Założony przez Evell.

Kilka szczegółów o moim forum:
wersja skryptu MyBB: 1.4.11
wersja bazy MySQL, Postgre: MySQLi 5.1.37
wersja używanego PHP: 5.2.10
adres forum: krema.pl
firma hostingowa: webh.pl
spis wtyczek: Wyłączyłem wszystkie
opis problemu:

Witam,
Mój problem polega na tym, że po wejściu w Style i szablony następnie w edytowanie szablonu (używam BSowo by Melivi) tabela, którą chce zapisać czyści się całkowicie. Np. Chce edytować stopkę, chce dodać do niej button, dodam kod i po naciśnięciu Zapisz i kontynuuj edycję cała tabela się czyści.
Nie mogę również zmienić stylu przez ACP ponieważ nie chce się rozwinąć ikonka Opcje.
Proszę o szybką pomoc.
DamYan napisał 28.02.2010, 23:53:
Pasuje do SiG - przenoszę.
Też to mam.
Gdy zrobisz jakiś błąd składniowy to czyści cały szablon lub ucina do momenty tego błędu.
Po prostu, zawsze wcześniej sprawdzaj czy wszystkie syntaxy się podświetlają, czy nie ma jakiś ukrytych tabów czy spacji.
No dobra, ale teraz jak chce wgrać oryginalny kod stopki to dzieję się to samo.
Wyślij mi na PW kod stopki to Ci oczyszcze.
Podaj tutaj kod stopki. :P
</div>
<div class="nav_sub">
<div>
<div style ="padding-right:10px; float:right;"><span class="smalltext"><a href="{$mybb->settings['contactlink']}">{$lang->bottomlinks_contactus}</a> | <a href="{$mybb->settings['homeurl']}">{$mybb->settings['homename']}</a> | <a href="#top">{$lang->bottomlinks_returntop}</a> | <a href="#content">{$lang->bottomlinks_returncontent}</a> | <a href="<archive_url>">{$lang->bottomlinks_litemode}</a> | <a href="{$mybb->settings['bburl']}/misc.php?action=syndication">{$lang->bottomlinks_syndication}</a></span>
</div></div>
</div>
<div class="footerbottom">
<div style ="padding-left:10px;">
<br />
{$lang->powered_by} <a href="http://www.mybboard.net" target="_blank">MyBB{$mybbversion}</a>, &copy; 2002-{$copy_year} <a href="http://www.mybboard.net" target="_blank">MyBB Group</a>.<br />
Theme Created By <a href="http://melivi.cba.pl" target="_blank">Melivi</a>, &copy; 2008-{$copy_year} <a href="http://mybboard.pl" target="_blank">MyBBoard.pl</a><br />
{$lang_select}
</div>
<!-- The following piece of code allows MyBB to run scheduled tasks. DO NOT REMOVE -->{$task_image}<!-- End task image code -->
{$auto_dst_detection}
</div>
</div>
</body>
</html>

Ja podałem stopkę jako przykład, ale np. gdy wejdę w inną tabelę i kompletnie nic w niej nie zmienię i zapiszę to ją też wyczyści.
Kod:
</div>
            <div class="nav_sub">
                <div>
<div style ="padding-right:10px; float:right;"><span class="smalltext"><a href="{$mybb->settings['contactlink']}">{$lang->bottomlinks_contactus}</a> | <a href="{$mybb->settings['homeurl']}">{$mybb->settings['homename']}</a> | <a href="#top">{$lang->bottomlinks_returntop}</a> | <a href="#content">{$lang->bottomlinks_returncontent}</a> | <a href="<archive_url>">{$lang->bottomlinks_litemode}</a> | <a href="{$mybb->settings['bburl']}/misc.php?action=syndication">{$lang->bottomlinks_syndication}</a></span>
                </div></div>
            </div>
<div class="footerbottom">
<div style ="padding-left:10px;">
<br />
{$lang->powered_by} <a href="http://www.mybboard.net" target="_blank">MyBB{$mybbversion}</a>, &copy; 2002-{$copy_year} <a href="http://www.mybboard.net" target="_blank">MyBB Group</a>.<br />
Theme Created By <a href="http://melivi.cba.pl" target="_blank">Melivi</a>, &copy; 2008-{$copy_year} <a href="http://mybboard.pl" target="_blank">MyBBoard.pl</a><br />
{$lang_select}
</div>
<!-- The following piece of code allows MyBB to run scheduled tasks. DO NOT REMOVE -->{$task_image}<!-- End task image code -->
{$auto_dst_detection}
</div>
        </div>
</body>
</html>
Nic nie dało, możliwe że to jakiś robak? Zauważyłem że podczas ładowania forum, ładuje również jakąś inną stronę (xtube-com czy jakoś tak).
To swoją drogą.
U mnie da się to wstukać w szablon. Ucina Ci całe, czy tylko w którymś momencie?
Chcesz to wyślij mi cały szablon na PW to Ci odeśle gotowy.

A co dor robaka.
Szukajką w szablonach poszperaj za jakimiś iframe, ale możliwe że xtube to jakiś dod. hosting plików na który ktoś wrzucił obrazek.
mialem to samo wczoraj. wyczyscilem(mozilla) ciastka wszedlem z innej przegladarki tj. opery wkleilem stopke z oryginalu i pomoglo...zapisalo szablon...sprobuj moze pomoze ci
adolf zrobiłem tak jak napisałeś, nie pomogło.
wujas napisz mi jakie pliki mam Ci wysłać, bo nie znam się na tym.
Wyeksportuj styl i podeślij na PW.
To niemożliwe, aby "samo się czyściło". Najpierw sprawdź, czy masz poprawne pliki .js, podmień je z oryginalnej paczki.
Sprawdź, czy podobnie dzieje się na stylu standardowym. Jeśli stracisz stopkę - jest opcja Przywróć oryginał w ACP, więc nie będzie problemu z odzyskaniem.
(28.02.2010, 23:52)DamYan napisał(a): Sprawdź, czy podobnie dzieje się na stylu standardowym. Jeśli stracisz stopkę - jest opcja Przywróć oryginał w ACP, więc nie będzie problemu z odzyskaniem.

Nie mogę zmienić stylu przez ACP, da się to jakoś zrobić przez phpmyadmin?
Gdzie jest ta opcja Przywróć oryginał?

Podobne wątki

Błąd Prywatne Wiadomości - brak miejsca na informacje tabel

23.09.2015, 20:33
Ostatni post: Radarr

Styl Zmiana tabel boardstats

13.09.2015, 08:45
Ostatni post: Supryk

Styl Zmodyfikowanie tabel działów

28.03.2014, 21:33
Ostatni post: SLAVOO

Błąd Brak zmiany koloru tabel, w czym błąd ?

28.10.2013, 22:17
Ostatni post: Anubis_Ostatni

Styl [SOLVED]Wyrównanie tabel

20.11.2012, 21:17
Ostatni post: Invisible97

Skocz do:

Użytkownicy przeglądający ten wątek:

1 gości