Błąd Problem z buttonem edytuj

Założony przez gielet.

wersja skryptu MyBB: 1.6.2
adres forum: -----------
na czym polega problem (screen, opis, komunikaty, nazwa stylu/theme/szablonu): Nie wiem jak to poprawić, a dokładniej chodzi mi o to że nie wiem jak poprawić używanie klawisza "Edytuj" w widoku posta.
Tj. nie ma w nim rozwijanej listy opcji np. "Pełna edycja" itp.
Gdzie, co i jak dodać?:confused:
TaniDedyk.pl
Spróbuj tak: ACP > style i szablony > szablony > twój styl > opis posta > postbit_edit
Wklej to:
Kod:
<a href="editpost.php?pid={$post['pid']}" id="edit_post_{$post['pid']}"><img src="{$theme['imglangdir']}/postbit_edit.gif" alt="{$lang->postbit_edit}" title="{$lang->postbit_edit}" /></a>
<div id="edit_post_{$post['pid']}_popup" class="popup_menu" style="display: none;"><div class="popup_item_container"><a href="javascript:;" onclick="Thread.quickEdit({$post['pid']});" class="popup_item">{$lang->postbit_quick_edit}</a></div><div class="popup_item_container"><a href="editpost.php?pid={$post['pid']}" class="popup_item">{$lang->postbit_full_edit}</a></div></div>
<script type="text/javascript">
// <!--
    if(use_xmlhttprequest == "1")
    {
        new PopupMenu("edit_post_{$post['pid']}");
    }
// -->
</script>

Jeszcze przed tym skopiuj, to co teraz tam masz - tak w razie czego ;)


Pozdrawiam!
Dalej tak jest, zmieniłem &gt; oraz &lt; na html`owe odpowiedniki bo wywalało błąd.
A na innym stylu też tak jest?


Pozdrawiam!
nie, tylko w [K]Inferno.


<a href="editpost.php?pid={$post['pid']}" id="edit_post_{$post['pid']}"><img src="{$theme['imglangdir']}/postbit_edit.gif" alt="{$lang->postbit_edit}" title="{$lang->postbit_edit}" /></a>
<div id="edit_post_{$post['pid']}_popup" class="popup_menu" style="display: none;"><div class="popup_item_container"><a href="javascript:;" onclick="Thread.quickEdit({$post['pid']});" class="popup_item">{$lang->postbit_quick_edit}</a></div><div class="popup_item_container"><a href="editpost.php?pid={$post['pid']}" class="popup_item">{$lang->postbit_full_edit}</a></div></div>
<script type="text/javascript">
// <!--
if(use_xmlhttprequest == "1")
{
new PopupMenu("edit_post_{$post['pid']}");
}
// -->
</script>



Może powyższy kod pomoże. Brany jest z oryginalnego stylu MyBB.
nic to nie dało.
A dodajesz to w szablonach tego stylu?
Bo obydwa kody są z oryginalnego stylu.


Pozdrawiam!
tak, chyba coś jeszcze trzeba z edytować.
MAsz na forum dodane coś z jquery ? Jesli tak to raczej w tym szukaj przyczyny i zastosuj "jQuery.noConflict"
menu mam w jQuery, jak zastosować to "jQuery.noConflict"?:)


Użytkownicy przeglądający ten wątek:

1 gości