Nest

Błąd Menu nad logiem

Założony przez Inaro.

Kilka szczegółów o moim forum i stylu, z którym mam problem:
nazwa stylu: CleanBuzz
wersja skryptu MyBB: 1.6
adres forum: localhost
opis problemu: Hej, skopiowałem ze stylu Royal do CleanBuzz menu nad logiem lecz nie za bardzo działa pewnie to wina CSS tak?

Gdy dodałem to wszystko to efekt jest taki: zdjęcie
Kod menu:
<div class="menu2">
<ul>
<li><a href="{$mybb->settings['bburl']}/search.php">&nbsp;&nbsp;{$lang->toplinks_search}</a></li>
<li><a href="{$mybb->settings['bburl']}/memberlist.php">&nbsp;&nbsp;{$lang->toplinks_memberlist}</a></li>
<li><a href="{$mybb->settings['bburl']}/calendar.php">&nbsp;&nbsp;{$lang->toplinks_calendar}</a></li>
<li><a href="{$mybb->settings['bburl']}/misc.php?action=help">&nbsp;&nbsp;{$lang->toplinks_help}</a></li>
</ul>
</div>
Kod CSS do menu:
.menu2 {
padding-left: 45px;
}

.menu2 ul {
background: #b7ad70 url(images/royal/menu_bg.png) top left repeat-x;
width: 95%;
color: #2d3e11;
text-align: center;
padding: 4px;
height: 21px;
border-left: 1px solid #929283;
border-right: 1px solid #929283;
border-bottom: 1px solid #929283;
-webkit-border-bottom-right-radius: 10px;
-moz-border-radius-bottomright: 10px;
-moz-border-radius-bottomleft: 10px;
-webkit-border-bottom-left-radius: 10px;
border-bottom-right-radius: 10px;
border-bottom-left-radius: 10px;

font-family: georgia;
font-size: 13px;
}

.menu2 ul a:link {
color: #50310f;
text-decoration: none;
font-family: georgia;
}

.menu2 ul a:visited {
color: #50310f;
text-decoration: none;
font-family: georgia;
}

.menu2 ul a:hover, .menu ul a:active {
color: #fff;
text-shadow: #497007 0px 1px 0px;

text-decoration: none;
font-family: georgia;
}
Próbowałem coś wykombinować na własnym stylu:

kod menu:
Kod:
<div class="navbar">
                <ul id="nav">
                    <li><a href="{$mybb->settings['bburl']}/search.php">&nbsp;&nbsp;{$lang->toplinks_search}</a></li>
                    <li><a href="{$mybb->settings['bburl']}/memberlist.php">&nbsp;&nbsp;{$lang->toplinks_memberlist}</a></li>
                    <li><a href="{$mybb->settings['bburl']}/calendar.php">&nbsp;&nbsp;{$lang->toplinks_calendar}</a></li>
                    <li><a href="{$mybb->settings['bburl']}/misc.php?action=help">&nbsp;&nbsp;{$lang->toplinks_help}</a></li>
                </ul>
            </div>

a w CSS:
navbar:
Kod:
height: 32px;
margin: 0;
padding: 0;
line-height: 32px;
border-top-width: 1px;
border-bottom-width: 1px;
border-top-style: solid;
border-bottom-style: solid;
border-top-color: #2b2b2b;
border-bottom-color: #2b2b2b;
text-align: center;
nav:
Kod:
list-style: none;
float: left;
margin: 0;
padding: 0;
text-align: center;

i było dobrze, spróbuj to dopisać
Dobra poradziłem sobie już sam... ale dzięki za pomoc :D

Podobne wątki

Błąd Menu wyświetlania menu użytkownika

09.10.2016, 10:14
Ostatni post: ficus

Jak zmienić belkę nad logiem i w statystykach forum - na dole

03.09.2016, 12:32
Ostatni post: F4taL

Inne Obrazek nad odnośnikiem w nagłowku

27.06.2016, 21:04
Ostatni post: Soapsss

Błąd Problem z logiem

30.04.2016, 15:36
Ostatni post: Lancinho

Styl Tłumaczenie podsumowania nad stopką.

28.02.2016, 15:11
Ostatni post: Tastey

Skocz do:

Użytkownicy przeglądający ten wątek:

1 gości