Nest

Błąd Działy nie zwijają się

Założony przez Sammyy.

Kilka szczegółów o moim forum i stylu, z którym mam problem:
nazwa stylu:
wersja skryptu MyBB: 1.6
adres forum: http://freetalk.pl
opis problemu:

No więc dodałem do swojego forum (dokładniej w indexie) następujący kod:

Kod:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="pl" lang="pl">
<head>
    <meta http-equiv="Content-type" content="application/xhtml+xml; charset=utf-8" />
    <title>Wysuwany panel menu w jQuery</title>

    <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js"></script>

    <link rel="stylesheet" href="panel.css" type="text/css" />

    <script type="text/javascript">
    
$(function(){

    $("#panel").css("right","-222px");

    $(".slide_button").toggle(function(){

        $("#panel").animate({right: "0px"}, 500 );
        $(this).addClass("zamknij");
        return false;
    },
    function(){    
        $("#panel").animate({right: "-220px"}, 500 );
        $(this).removeClass("zamknij");
        return false;
    });

});


    </script>


    <!--[if lt IE 8]>
    <script src="http://ie7-js.googlecode.com/svn/version/2.0(beta3)/IE8.js" type="text/javascript"></script>
    <![endif]-->
</head>
<body>


<div id="panel">

    <ul id="main_menu">
              <script src="http://widgets.twimg.com/j/2/widget.js"></script>
<script>
new TWTR.Widget({
  version: 2,
  type: 'profile',
  rpp: 20,
  interval: 6000,
  width: 'auto',
  height: 250,
  theme: {
    shell: {
      background: '#763849',
      color: '#b8b893'
    },
    tweets: {
      background: '#f6f6e9',
      color: '#000000',
      links: '#763849'
    }
  },
  features: {
    scrollbar: true,
    loop: true,
    live: false,
    hashtags: true,
    timestamp: false,
    avatars: false,
    behavior: 'default'
  }
}).render().setUser('Sacchi_pl').start();
</script>
       </ul>

    <a href="#" class="slide_button" >Menu</a>

</div>

</body>
</html>

Wszystko działa jak należy, jedyny problem to fakt że działów (jak i statystyk) nie da się zwinąć klikając na [Obrazek: collapse.gif].
Dodając to do headerinclude oczywiście występuje ten sam problem. Bez powyższego kodu wszystko działa jak należy jednak zależy mi na obu.

EDIT:

Przy okazji jeszcze, w tagach wszystko działa jak należy.
Nie wiem czy dobrze skumałem ,ale chcesz zrobić zwijanie tabel?
Kod:
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="border">
<thead>
<tr>
<td class="thead" colspan="3">
<div class="expcolimage"><img src="{$theme['imgdir']}/collapse.png" id="cat_{$forum['fid']}_img" class="expander" alt="{$expaltext}" title="{$expaltext}" /></div>
<div><strong><a href="{$forum_url}">{$forum['name']}</a></strong><br /><div class="smalltext">{$forum['description']}</div></div>
</td>
</tr>
</thead>
<tbody style="{$expdisplay}" id="cat_{$forum['fid']}_e">
<tr>
<td class="tcat" colspan="1"></td>
<td class="tcat" colspan="1"><strong>{$lang->forumbit_forum}</strong></td>
<td class="tcat" width="300" align="center"><strong>{$lang->forumbit_lastpost}</strong></td>
</tr>
{$sub_forums}
</tbody>
</table>
To przykładowa tabela...
Warunkiem do 'zwijania' się jej jest:
W opcji thead -
Kod:
id="coś_img"
W opcji tbody -
Kod:
id="coś_e"
Nie, nie chodzi mi o to.
Jeśli zakładasz na forum kategorię to klikając po prawej możesz ją zwinąć by nie widzieć działów forum należących do tejże. Problem polega na tym że klikając na zwinięcie kategoria nie zwija się i problemem jest kod który wyżej podałem (kod dodaje zwijający się panel po prawej stronie co widać u mnie na forum klikając na grafikę [Obrazek: przycisk.gif]). Widać powyższy kod w jakiś sposób koliduje z tamtym, pytam czy jest jakieś rozwiązanie by te dwie rzeczy razem współpracowały.

Przykładowo taki na dole strony można zwinąć bez problemu, jednak nie mam pojęcia czemu.

Twój powyższy kod to standard jest i nic mi to nie da bo tak mam.

Podobne wątki

Błąd Działy Like IPB 3

08.10.2016, 22:49
Ostatni post: Antymed

Błąd Nie wyświetlają się działy i kategorie

23.08.2016, 09:22
Ostatni post: Black Angels

Styl Linię oddzielające działy

04.08.2016, 13:49
Ostatni post: Kamil01

Błąd Kolorowe działy

14.07.2016, 16:22
Ostatni post: Divir

Szukam Opis forum pod nazwą forum (działy/forum)

21.06.2016, 18:42
Ostatni post: Ardex

Skocz do:

Użytkownicy przeglądający ten wątek:

1 gości